Some Clients Have Reported Issues with Offer Letters
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Mar 23, 2020 - 16:24 PDT
Investigating
We are investigating an issue where some users have reported that they can't send offer letters.
Posted Mar 23, 2020 - 16:02 PDT
This incident affected: Offer letters.