Delayed Document Processing
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Mar 16, 2020 - 15:58 PDT
Monitoring
Some users may experience delay in Offer Letter and Message Template creations and sending them out. We're monitoring the situation.
Posted Mar 16, 2020 - 13:54 PDT
This incident affected: Offer letters and Form builder.