Offer Letter and Send Documents Delay
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Jul 29, 2020 - 16:20 PDT
Identified
we are currently experiencing issues with offer letters and documents
Posted Jul 29, 2020 - 15:23 PDT
This incident affected: Offer letters.