Some users may experience a delay in search indexing new applicants
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Apr 24, 2023 - 14:31 PDT
Identified
We are experiencing a delay in search indexing new applications. There may be a delay for applications submitted today appearing in search results or certain filters. No data has been lost and the delay should be resolved shortly. We apologize for any inconvenience that this has caused.
Posted Apr 24, 2023 - 11:24 PDT
This incident affected: Application Viewer.