Some Users May Experience Delays with Reference Checks

Incident Report for Applicant Tracking Software

Resolved

Our Reference Check provider has confirmed that the outage has been fully resolved. All systems are operating normally, and Reference Check requests are being processed as expected.

Any requests held during the outage have now been released for processing, and candidates and their references should have full access to complete their surveys.

We appreciate your patience while this issue was addressed.
Posted Oct 29, 2025 - 15:06 PDT

Monitoring

Our Reference Check provider has resolved the earlier service outage, and functionality has been restored.

All pending Reference Check requests are now being processed, and candidates and their references should be able to access the system normally.

We are monitoring to ensure full stability and will provide a final update once the issue is confirmed resolved.
Posted Oct 29, 2025 - 13:25 PDT

Identified

Our Reference Check provider is currently experiencing a service outage. While hiring managers can still submit new Reference Check requests, there will be a delay before they are processed.

This issue also affects previously submitted Reference Checks — candidates and their references may not be able to access the system to provide or complete reference information during this time.

Our Support Team does not have visibility into the status or progress of these requests while the provider’s service is unavailable. However, all pending and new requests are being held and will be processed automatically once the provider is back online.

We will provide updates as more information becomes available.
Posted Oct 29, 2025 - 11:41 PDT
This incident affected: Third Party Services.