Users may be experiencing slower page load times in the ATS platform

Incident Report for Applicant Tracking Software

Resolved

We have identified and resolved the underlying issue. We will continue to monitor.
Posted Nov 01, 2021 - 11:54 PDT

Update

Performance is almost back to normal. Our team is still working to get to 100%.
Posted Nov 01, 2021 - 10:23 PDT

Investigating

We are currently investigating this issue.
Posted Nov 01, 2021 - 09:04 PDT