There May Be Some Delays With Messaging
Incident Report for Applicant Tracking Software
Postmortem

Incident Summary: From June 13, 2024, to July 16, 2024, we observed intermittent delays to emails sent from our platform to Yahoo, AOL, and Verizon email addresses.

Customer Impact: Some emails sent from our platform experienced a slight delay in delivery to email addresses using Yahoo, AOL, or Verizon email services. Users were advised to utilize alternative communication methods (SMS or a different email provider) for impacted recipients.

Root Cause: Yahoo/AOL email service providers recently started requiring additional features for handling high email volumes, which led to unexpected delays in our email deliveries.

Resolution Steps: Our team was already working on implementing the required features to meet the new expectations for bulk email senders with high volumes. This requirement has been deployed and we are no longer seeing a delay in email delivery. 

Preventative Measures: Our team is enhancing the monitors in place for our email processing infrastructure. Thank you for your patience and understanding as we continue to improve your experience with our services.

If you have any further questions or concerns, please do not hesitate to reach out to our support team.

Posted Jul 22, 2024 - 10:39 PDT

Resolved
With the assistance of the third-party email providers, we have successfully resolved the issue. We appreciate your patience as we collaborated with them to address this matter.
Posted Jul 16, 2024 - 12:02 PDT
Update
We are continuing to work with the third-party email providers to resolve the issue.
Posted Jul 15, 2024 - 09:32 PDT
Update
No additional news to share at this time. We apologize for the continued trouble.
Posted Jul 12, 2024 - 10:36 PDT
Update
We are actively working on this issue and appreciate your continued patience as we collaborate with third parties to resolve it. Thank you for your understanding.
Posted Jul 11, 2024 - 11:09 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 10, 2024 - 09:28 PDT
Update
No additional news to share just yet. We apologize for the continued trouble and appreciate your continued patience.
Posted Jul 09, 2024 - 10:47 PDT
Update
We are continuing to work with the third-party email providers to resolve the issue. We apologize for any inconvenience this may cause and appreciate your understanding.
Posted Jul 08, 2024 - 08:28 PDT
Update
No additional news to share just yet, but we’re focused on getting things back to normal as quickly as we can. We apologize for the continued trouble.
Posted Jul 03, 2024 - 08:46 PDT
Identified
We are actively collaborating with third parties to resolve the issue, and we are beginning to see signs of improvement. We sincerely appreciate your continued patience and apologize for any inconvenience caused.
Posted Jul 02, 2024 - 11:40 PDT
Update
We are continuing to investigate this issue. More updates will follow as soon as possible.
Posted Jul 01, 2024 - 10:47 PDT
Update
We're actively working on this issue, but we don't have any new information to share. We appreciate your continued patience while we work towards getting things back to normal.
Posted Jun 28, 2024 - 09:12 PDT
Update
No additional news to share just yet, but we’re focused on getting things back to normal as quickly as we can. We apologize for the continued trouble.
Posted Jun 27, 2024 - 07:50 PDT
Update
We are continuing to work with the third-party email providers to identify the issue. We apologize for any inconvenience this may cause and appreciate your understanding.
Posted Jun 26, 2024 - 08:13 PDT
Update
No additional news to share just yet. We apologize for the continued trouble.
Posted Jun 25, 2024 - 07:06 PDT
Update
We are continuing to work with the third-party email providers to identify the issue. We apologize for any inconvenience this may cause and appreciate your understanding.
Posted Jun 24, 2024 - 06:22 PDT
Update
No additional news to share just yet. We apologize for the continued trouble and appreciate your continued patience.
Posted Jun 20, 2024 - 10:02 PDT
Update
We're actively working on this issue, but we don't have new information to share at the moment. We appreciate your patience while we get things back to normal.
Posted Jun 18, 2024 - 07:41 PDT
Update
No additional news to share just yet, but we’re focused on getting things back to normal as quickly as we can. We apologize for the continued trouble.
Posted Jun 17, 2024 - 14:17 PDT
Investigating
Our technical team is currently working with the third-party email providers to identify the issue causing messaging delays. We understand the importance of smooth communication during the hiring process and are dedicated to resolving this as quickly as possible.

Here's what we know so far:

-Messaging delays are happening intermittently with certain email service providers: Yahoo, AOL, and Verizon.
-The issue is only affecting some users.
-We are actively investigating the cause of the problem in collaboration with the email providers.

In the meantime, please:

-Use alternative communication channels, such as alternative email addresses or phone calls, to reach your candidates.

We apologize for any inconvenience this may cause and appreciate your understanding.
Posted Jun 17, 2024 - 10:02 PDT
This incident affected: Messages.