Some Clients May Have Issues Accessing Their Account
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Nov 04, 2020 - 14:34 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 04, 2020 - 14:31 PST
Investigating
We are currently investigating the issue.
Posted Nov 04, 2020 - 14:25 PST
This incident affected: Careers page, Offer letters, Message templates, Form builder, and Background checks.