Some users logging in from integrated systems may encounter an issue accessing Hiring/ATS
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Oct 02, 2020 - 15:59 PDT
Monitoring
Some users logging in from integrated systems may encounter an issue with accessing the system; if you clear your browser's cookies and cache and restart the browser, this should clear the issue.
Posted Oct 02, 2020 - 12:51 PDT