Some users may experience issues with offer letters and documents
Incident Report for Applicant Tracking Software
Resolved
HelloSign has implemented a fix and is monitoring the results.
Posted Nov 17, 2020 - 12:47 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 17, 2020 - 12:17 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2020 - 12:12 PST
Investigating
HelloSign is currently investigating slowness which may be impacting users attempting to add onboarding documents or use the Send Documents feature. Some users may experience issues adding documents and sending offer letters. HelloSign is currently working on a solution. Once resolved, onboarding documents and offer letters will be functional.
Posted Nov 17, 2020 - 11:55 PST
This incident affected: Offer Letters.