Switch Accounts Menu Temporarily Unavailable for Some Users

Incident Report for Applicant Tracking Software

Resolved

The Account Switcher will remain disabled while we continue making behind-the-scenes improvements to the feature. We’ll restore it once the work is complete and will post an update in our Changelog when it’s re-enabled. In the meantime, users will need to access accounts individually.
Posted Aug 11, 2025 - 14:38 PDT

Identified

We’ve temporarily removed the functionality powering the Switch Accounts menu in the application. As a result, this menu is currently not appearing for users.

Impact:
Users who typically use the Switch Accounts feature will notice it is unavailable at this time. This change was made proactively as we address an issue affecting the endpoint that populates this menu.

Next Steps:
We are actively working on a resolution and will restore the feature once the underlying issue is fully resolved.

We appreciate your patience and understanding.
Posted Jul 24, 2025 - 12:04 PDT
This incident affected: Account Access.