Offer Letter and Send Documents experiencing intermittent outages
Incident Report for Applicant Tracking Software
Resolved
Service is back to normal and the incident is resolved.
Posted Oct 16, 2020 - 12:30 PDT
Update
We are continuing to investigate this issue.
Posted Oct 16, 2020 - 12:30 PDT
Investigating
Our third party e-signature provider is experiencing intermittent outages with document and signature actions.
Posted Oct 16, 2020 - 11:24 PDT
This incident affected: Offer letters.