Service Disruption
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted May 03, 2023 - 16:10 PDT
Update
We have resolved the incident and our Engineering Team is continuing to monitor.
Posted May 03, 2023 - 14:27 PDT
Update
We are continuing to investigate this issue.
Posted May 03, 2023 - 14:09 PDT
Update
Some users may still be experiencing issues when accessing the system.

Our Engineering Team is working on a resolution.
Posted May 03, 2023 - 13:47 PDT
Update
We're actively working on this issue, but we don't have new information to share at the moment. We appreciate your patience while we get things back to normal.
Posted May 03, 2023 - 13:32 PDT
Investigating
We are currently experiencing a service disruption.

Our Engineering Team is working to identify the root cause and implement a solution.

We will send an additional update in 20 minutes.
Posted May 03, 2023 - 13:12 PDT
This incident affected: Account Access.