Lag/Slowdown in Document Handling with Offer Letters & Documents
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 11, 2019 - 13:27 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Jul 11, 2019 - 13:03 PDT
Update
We are continuing to investigate this issue.
Posted 2 months ago. Jul 11, 2019 - 12:27 PDT
Investigating
You may experience a slowdown in document handling operations with offer letters and documents, such as document uploads, final document delivery, and similar events. This is currently being investigated.
Posted 2 months ago. Jul 11, 2019 - 12:27 PDT
This incident affected: Offer letters.