Error with Sending Onboarding Documents
Incident Report for Applicant Tracking Software
Resolved
This issue has been resolved
Posted 19 days ago. Jul 02, 2019 - 16:21 PDT
Investigating
Some clients have reported offer letters & onboarding documents aren't working;
we're investigating into this issue. We sincerely apologize for any inconvenience this has caused.
Posted 19 days ago. Jul 02, 2019 - 15:26 PDT
This incident affected: Offer letters.