Some Users May Be Experiencing Issues with Addresses Not Displaying in Applicant Profiles

Incident Report for Applicant Tracking Software

Resolved

This issue has been fully resolved, and all affected data has been successfully restored. Addresses are now displaying correctly on both newly received and past applications. Thank you for your patience and understanding!
Posted Feb 13, 2025 - 13:53 PST

Monitoring

A fix has been implemented, and addresses are now displaying as expected on newly received applications. We will continue monitoring to ensure everything is working smoothly. Thank you for your patience!
Posted Feb 13, 2025 - 11:49 PST

Investigating

Our team is aware of an issue where addresses submitted through the application form are not displaying in applicant profiles. We are actively investigating the cause and working toward a resolution as quickly as possible. We apologize for any inconvenience this may cause.
Posted Feb 13, 2025 - 08:01 PST
This incident affected: Application Viewer.