Some users are experiencing an SSO login error

Incident Report for Applicant Tracking Software

Resolved

This issue has been fully resolved. SSO logins are working as expected.

If you still can’t access your account via SSO, please contact Support.
Posted Sep 29, 2025 - 10:05 PDT

Monitoring

A solution was deployed overnight, and SSO logins should now be functioning as expected. We are continuing to monitor the situation and apologize for any inconvenience caused.

If you are still experiencing issues accessing your account via SSO, please reach out to our Support team for assistance.
Posted Sep 27, 2025 - 06:03 PDT

Identified

A resolution is in progress and a fix will be implemented soon. In the meantime, please continue to use the direct login option if you are unable to access the ATS via SSO.

-Go to your company’s careers page.
-Scroll to the bottom right and click on Admin Login.
-Enter your direct login credentials. (If you don’t already have a direct login, select Forgot Password to create one.)
Posted Sep 26, 2025 - 10:47 PDT

Investigating

Some users may be experiencing a 500 error when attempting to access the ATS via SSO from another platform. As a workaround, users can log in by navigating to the careers page, clicking on the "Admin Login" link at the bottom right and logging in directly.
Posted Sep 26, 2025 - 07:56 PDT
This incident affected: Account Access.