Some users have reported delays with Email, job placements, and other background operations
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 11, 2019 - 16:58 PDT
Update
The issue is resolved and we and now working through our backlog.
Posted 2 months ago. Jul 11, 2019 - 16:07 PDT
Investigating
You may also experience a slowdown in document handling operations with offer letters and documents, such as document uploads, final document delivery, and similar events. We are working to resolve this issue.
Posted 2 months ago. Jul 11, 2019 - 15:53 PDT