Issues with Offer Letters & Documents
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Apr 30, 2021 - 07:08 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2021 - 16:19 PDT
Investigating
Some users may be experiencing issues with Documents and Offer Letters within their accounts. We are working closely with our document partner and will have this resolved shortly. We do apologize for any inconvenience this may cause.
Posted Apr 29, 2021 - 13:59 PDT
This incident affected: Offer letters.