Some Users are Experiencing Delays in Background Job Processing

Incident Report for Applicant Tracking Software

Resolved

Our background job queues are now fully caught up, and we’re processing jobs as expected again. Huzzah!

Just to clarify—when we refer to background jobs, we're talking about automated processes that run behind the scenes in the system. These include things like sending emails, processing bulk updates, generating reports, and similar actions. This is separate from background checks, which were not affected.

Thanks for your patience while we resolved the issue!
Posted Aug 04, 2025 - 14:37 PDT

Investigating

We’re currently experiencing significant delays in background job processing. This is affecting several key functions, including:

-Email delivery
-Bulk updates
-Report generation
-Other time-sensitive automated actions

Our team is actively working to mitigate the issue and restore normal performance as quickly as possible. We’ll continue to provide updates here as we make progress.

Thank you for your patience, and we apologize for the disruption.
Posted Aug 04, 2025 - 13:55 PDT
This incident affected: Reports.