Some users may encounter errors when attempting to view new applicants
Incident Report for Applicant Tracking Software
Resolved
A fix has been implemented.
Posted Sep 07, 2021 - 13:27 PDT
Identified
The issue has been identified and a fix is being implemented. New incoming applications should be visible and a fix is being implemented for applications received this morning.
Posted Sep 07, 2021 - 12:21 PDT
Investigating
We have identified an issue that is currently causing an error message to display when attempting to view new applicants. Our team is working diligently to correct this issue.
Posted Sep 07, 2021 - 10:59 PDT
This incident affected: Application Viewer.