Users reporting can't access accounts
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Dec 02, 2019 - 08:33 PST
Investigating
Some users have reported that they can't access their accounts. We are investigating the issue.
Posted Dec 02, 2019 - 08:29 PST
This incident affected: Careers page, Offer letters, Message templates, Form builder, Background checks, and Help.