Users Have Reported Issues Downloading Applicant Files
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Mar 29, 2020 - 10:49 PDT
Investigating
We are currently investigating this issue, some users may experience an error message when attempting to download applicant files. We apologize for any inconvenience this may cause.
Posted Mar 29, 2020 - 10:36 PDT