Some users may be experiencing issues with background checks and/or I-9/E-Verify
Incident Report for Applicant Tracking Software
Resolved
Our third party background check vendor has confirmed that they are back online.
Posted Sep 25, 2020 - 15:29 PDT
Identified
Here is an update from the third party background check provider: We're still working hard to solve the server issues, and we estimate between 1-2 hours before things are back online. Thank you for your patience.
Posted Sep 25, 2020 - 12:26 PDT
Investigating
A third party background check provider is currently rebooting their system and their services are offline temporarily. Services should be back online shortly.
Posted Sep 25, 2020 - 10:31 PDT
This incident affected: Background/Drug Screening.