I-9 and Background Check Issues
Incident Report for Applicant Tracking Software
Resolved
Our vendor has fixed the issue. All failures have been resolved within the accounts that were affected.
Posted Jan 15, 2021 - 19:22 PST
Investigating
Customers have reported issues when ordering custom background check packages and I-9s. We are working with our partner to resolve these issues.
Posted Jan 15, 2021 - 15:37 PST
This incident affected: Background/Drug Screening.