Intermittent issue with daily notification email delivery
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 16, 2019 - 09:17 PDT
Identified
We are continuing to work on the daily notification issue.
Posted 3 months ago. Apr 12, 2019 - 09:14 PDT
Investigating
Some hiring managers are not receiving daily notification emails.
Posted 3 months ago. Apr 08, 2019 - 08:01 PDT