Some Users May Not Be Able to Order Background Checks
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Nov 25, 2020 - 16:09 PST
Investigating
Some users may not be able to order background checks; specifically those who have custom packages. We're monitoring the situation heading into the Holiday weekend and will be providing updates as we get them. Thank you for your patience with this. Have a wonderful and safe Thanksgiving!
Posted Nov 25, 2020 - 15:21 PST
This incident affected: Background/Drug Screening.