ATS is unavailable for all customers
Incident Report for Applicant Tracking Software
Resolved
Service has been restored.
Posted 3 months ago. Apr 30, 2019 - 18:06 PDT
Update
We are at reduced capacity and there may be certain services that are still unavailable, our apologies
Posted 3 months ago. Apr 30, 2019 - 17:24 PDT
Identified
All systems are currently unavailable
Posted 3 months ago. Apr 30, 2019 - 17:12 PDT