'Temporarily Unavailable' Message on Applicant Report Page for Some Users

Incident Report for Applicant Tracking Software

Resolved

This incident is now resolved.
Posted Sep 11, 2025 - 09:52 PDT

Update

Our team is continuing to investigate the issue where some users may see a “Temporarily Unavailable” message on the Applicant Report page. We don’t have any new updates to share at this time, but please know that resolving this remains a top priority.

As a workaround, affected users can still retrieve applicant data by navigating to Reports > Downloads to access downloadable reports.

We appreciate your continued patience and will provide another update as soon as more information becomes available.
Posted Sep 11, 2025 - 08:33 PDT

Update

We’re still actively investigating the issue where some users may see a “Temporarily Unavailable” message on the Applicant Report page. We apologize for any inconvenience this may be causing and appreciate your patience as we work to resolve it.

In the meantime, affected users can access downloadable reports as an alternative way to retrieve applicant data by navigating to Reports > Downloads.
Posted Sep 10, 2025 - 05:32 PDT

Investigating

We’re currently investigating an issue where some users may be seeing a “Temporarily Unavailable” message on the Applicant Report page.

In the meantime, affected users can access downloadable reports as an alternative way to retrieve applicant data by navigating to Reports > Downloads.
Posted Sep 09, 2025 - 06:42 PDT
This incident affected: Reports.