Account access issues
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted 10 days ago. Jul 11, 2019 - 17:41 PDT
Monitoring
A fix has been implemented and we're monitoring the situation.
Posted 10 days ago. Jul 11, 2019 - 17:10 PDT
Investigating
Some users are reporting issues accessing their account. We are currently investigating the issue.
Posted 10 days ago. Jul 11, 2019 - 16:38 PDT