Some Applications are not transferring through to the ATS
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Mar 30, 2020 - 13:30 PDT
Investigating
We've received reports that applications from applicants are not transferring through to the ATS; we're looking into this right now. Our sincerest apology for any inconvenience this has caused.
Posted Mar 30, 2020 - 11:10 PDT
This incident affected: Careers Page.