Some users May Not Be Able to View Their Job Grid on the Dashboard
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Oct 16, 2020 - 10:39 PDT
Identified
We've identified an issue that may impact some users being able to view their job grid on the dashboard. Please open your browser in incognito to view the job grid. We apologize for any inconvenience this has caused.
Posted Oct 16, 2020 - 10:20 PDT