Degraded Performance
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted Feb 29, 2024 - 06:41 PST
Identified
We are currently experiencing degraded performance of our UI and API. Users may encounter slower response times while using the ATS while we address the issue.
Posted Feb 29, 2024 - 04:56 PST
This incident affected: Account Access, Account Details, Application Viewer, Careers Page, Create/Edit Jobs, Messages, Offer Letters, and Reports.