Intermittent issue with daily notification email delivery
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 05, 2019 - 11:46 PDT
Investigating
Some hiring managers are not receiving daily notification emails.
Posted 6 months ago. Apr 05, 2019 - 10:48 PDT