Some Users May Not be Able to Create New Users

Incident Report for Applicant Tracking Software

Postmortem

Incident Summary

On March 12, 2025, we identified a bug that temporarily prevented users from being created on the Manage Users Page. From 11:00 AM to 2:13 PM PT, attempting to add a user resulted in a 404 error.

Customer Impact

From 11:00 AM to 2:13 PM PT, users attempting to add a new user on the Manage Users Page encountered an error, preventing them from successfully completing the action.

Root Cause

We released an enhancement to our JavaScript routing that inadvertently reordered a dependent route, which resulted in the unintended display of a 404 error to our users when attempting to “Add User” on the Manage Users Page. (JavaScript routing is the process of managing navigation within a web application without requiring full-page reloads.)

Resolution Steps

  • Our support team promptly escalated the user-reported issue to the engineering team.
  • The engineering team quickly determined that a change in JavaScript route ordering impacted functionality.
  • A fix was deployed to correct the routing changes, restoring full functionality.

Preventative Measures

  • A new integration test will be added to prevent future route ordering changes from inadvertently impacting platform function.

If you have any further questions or concerns, please do not hesitate to reach out to our Support Team.

Posted Mar 14, 2025 - 08:47 PDT

Resolved

We're happy to report that the issue preventing user creation on the Manage Users Page in Account Details has been resolved, and our team is actively monitoring the system to prevent future occurrences.

If you encounter any difficulties with user creation, we recommend clearing your cache and cookies. Should the issue persist, feel free to reach out to our Support Team. We're here, ready to assist if needed.

Thank you for your patience!
Posted Mar 12, 2025 - 14:19 PDT

Investigating

We’re currently in the midst of investigating an issue with user creation on the Manage Users Page in Account Details. Our dedicated team is on the case, diligently searching for the root cause.

Here's what we know so far:
- Users are currently unable to create new users on the Manage Users Page.
- The issue is affecting some users. Some accounts rely strictly on Single Sign-On (SSO) access and are therefore not affected.
- We are actively investigating the cause of the issue and will update this space as soon as we know more.

In the meantime, please:
- As a workaround, you can add new users via API or ask our Support Team to take that action on your behalf.
- Refresh your Applicant Tracking System page periodically to check if the issue has been resolved.

Your understanding and patience are greatly appreciated as we work to ensure the smooth operation of the Manage Users feature.
Posted Mar 12, 2025 - 13:41 PDT
This incident affected: Account Details.