Pages may be slow loading

Incident Report for Applicant Tracking Software

Resolved

This incident has been resolved.
Posted Nov 29, 2022 - 11:56 PST

Update

We are continuing to investigate this issue.
Posted Nov 29, 2022 - 11:11 PST

Investigating

The site is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. We're investigating the cause and will provide an update as soon as possible.
Posted Nov 29, 2022 - 11:10 PST
This incident affected: Application Viewer and Create/Edit Jobs.